Moodle Support

Java script inserting into my edtech

 
Patricia Smeyers
Java script inserting into my edtech
by Patricia Smeyers - Thursday, July 26, 2012, 10:54 PM
 

Please, I do hope that someone can finally help figure out my dreamweaver issue.  I finally found some java (that I did not insert) in my css code.  My pages are constantly changing appearnace along with errors.  Perhaps the server will insert it which is would be ok with me. Then I am not crazy seeing things for months.  Please advice and be sure my site in sandbox is ok.  Seems to have more access than I can figure out.  Here is the wierd css java scripting:

type='text/css' href='/B1D671CF-E532-4481-99AA-19F420D90332/netdefender/hui/ndhui.css' /><!--[if lt IE 8]><link rel='stylesheet' type='text/css' href='/B1D671CF-E532-4481-99AA-19F420D90332/netdefender/hui/ndhui_ie7.css' /><![endif]--><script type='text/javascript' lan i

My sandbox course http://edtechdev.mrooms2.net/course/view.php?id=305

My website http://edtech2.boisestate.edu/patriciasmeyers/512/WBI/home.html weird css is in the modules with many links so my  dreamweaver reads


Hope you tell me it isn't me for a change.  Thanks for your help in advance

 

Patrick Lowenthal
Re: Java script inserting into my edtech
by Patrick Lowenthal - Friday, July 27, 2012, 8:54 AM
 

Patricia 

I am happy to help but I need more context.

What you copied above is CS. The javascript was either not copied or stripped from moodle.

So I have some questions that will help me understand what has happened.

1. Is the issue you are having in moodle, the edtech2 server or both?

2. Did you purposely add the javascript or did you just notice it is there?

3. Are you having CSS issues AND javascript issues?

Please elaborate on the problem with specific examples.

Thanks

Patrick

Patricia Smeyers
Re: Java script inserting into my edtech
by Patricia Smeyers - Friday, July 27, 2012, 9:14 AM
 

Thank you for responding!  I designed a Moodle Course and used dreamweaver for the syllabus and lesson plans.  I did not install any java on the syllabus and linked a video on each lesson plan.  

All files are here and course link as well!

http://edtech2.boisestate.edu/patriciasmeyers/512/WBI/home.html

My pages seem to change the code.   From here my syllabus is now bold and Glori noticed my spacing went a bit off!  A few weeks back all websites were underlined!  Justba reminder too six months back I had a link hidden in my 501 page called wiki invest technology and this reads net defender and says something about bad tool.  I saved it but not sure safe to send.  

Sorry if frustrated if it's minor bit had to get two new computers routers from last adobe Trojan beginning of Jan.  

Not sure if this means anything but my windows 7 has no log in a lot just a blue screen until you unplug and restart.  Geek squad no help!

Patricia Smeyers
Re: Java script inserting into my edtech
by Patricia Smeyers - Friday, July 27, 2012, 10:01 AM
 

Forgot the file

Patrick Lowenthal
Re: Java script inserting into my edtech
by Patrick Lowenthal - Friday, July 27, 2012, 10:21 AM
 

Patricia

I am still a little confused.

It sounds like the same files you have in moodle are located on your edtech2 server so I am going to focus on those.

So let's first address the syllabus issue.

You said that the syllabus is all bold. That is likely b/c you are missing a closing tag.

So when looking at this:

http://edtech2.boisestate.edu/patriciasmeyers/dc/syllabus.html

When looking at your code, I think  the problem is in your CSS.

You have two instances that need to be fixed.

.style3 {
font-size: 14px
}

Should be

.style3 {
font-size: 14px;
}

This 

.style4 {
color: #FFFFFF
}

Should be

.style4 {
color: #FFFFFF;
}

This 

.style11 {
font-weight: bold
}

Should be

.style11 {
font-weight: bold
}

Make these changes and upload the new css file and we can trouble shoot some more if you still have issues with the syllabus.

Further, if a page is all underlined, it is likely simply in the HTML OR the CSS. A virus on your computer most likely won't cause problems like these.

Finally, I still don't see where there is Java or JavaScript giving you a problem. Can you tell me the exact page?

Thanks

Patrick

Patricia Smeyers
Re: Java script inserting into my edtech
by Patricia Smeyers - Friday, July 27, 2012, 11:03 AM
 

Here is my second file for you and I hope you agree we are looking at two different sources codes.  Mine injects this weird Css and makes it difficult to edit.

Patrick Lowenthal
Re: Java script inserting into my edtech
by Patrick Lowenthal - Friday, July 27, 2012, 12:50 PM
 

I'll take a look and get back with you. When you say you get a moodle error are you saying you are getting that when you try to copy/paste the HTML into moodle? Moodle doesn't like you adding too much custom css and it strips java script and other things.

let's take this out of moodle.

Please email me at patricklowenthal@boisestate.edu

Patrick

Patrick Lowenthal
Re: Java script inserting into my edtech
by Patrick Lowenthal - Friday, July 27, 2012, 12:52 PM
 

See this: http://forum.bitdefender.com/index.php?showtopic=27888

Do you have Bitdender installed on your computer?

Patrick